What needs to be done to make acorn-class-fileds and others work with acorn 7?

Is it enough to loosen the version check ?

I expect so, yes.