How to find which version of Tern is integrated with Firefox's Scrachpad?


#1

Hi,
First let me thank you for the amazing work you’ve done for Tern.
Some functions of Tern like Jump to definition by alt-. don’t work is Scratchpad of Firefox V. 37. Is it related to an older version of Tern and if yes, how can it be updated without updating FF?


#2

I don’t know much about Scratchpad, but if you can get at the tern module, it has a version property. Or if you can get at the source code, find tern.js and see what version it lists.

Alt-. has been in the package from the beginning though, so this is probably not a version problem.